Monday, September 26, 2011

Leased Line Configuration- Cisco 2900 Series Router

One of our clients decided to upgrade their Leased Line connection from 2Mbps to 8Mbps and bought Cisco 2900 Series Integrated Services Router. I was asked to configure which in the beginning I had some troubles in the configuration but later on, I finally made it working.

Below are the commands and configurations I had gone through to make it work.


*Setting up hostname and DHCP server
Router> en
Router#conf t
Router(config)# hostname HOTEL
HOTEL(config)#ip dhcp pool mypool
HOTEL(dhcp-config)#network 192.168.2.0 255.255.255.0
HOTEL(dhcp-config)#dns-server 213.42.20.20 195.22.241.222
HOTEL(dhcp-config)#default-router 192.168.2.1
HOTEL(dhcp-config)#ip name-server 213.42.20.20
HOTEL(dhcp-config)# exit


*Configure GigabitEthernet 0/0 for connection to the ISP public address which they  subscribed
HOTEL#conf t
HOTEL(config)# int GigabitEthernet 0/0
HOTEL(config-if)#ip add 83.111.95.77 255.255.255.252
HOTEL(config-if)#no shut
HOTEL(config-if)# ip nat outside
HOTEL(config-if)#exit


*Configure GigabitEthernet 0/1 for your LAN
HOTEL#conf t
HOTEL(config)# int GigabitEthernet 0/1
HOTEL(config-if)#ip add 192.168.2.1 255.255.255.0
HOTEL(config-if)#no shut
HOTEL(config-if)#ip nat inside
HOTEL(config-if)#exit
HOTEL(config)#


*Configure the Access-list
HOTEL(config)#ip nat inside source list 100 interface GigabitEthernet0/0 overload
HOTEL(config)#access-list 100 permit ip any any
HOTEL(config)#ip route 0.0.0.0 0.0.0.0 83.111.95.77
HOTEL(config)#exit
HOTEL#copy run start  <--- Save the configuration. Don't ever forget this command.

Goodluck!










2 comments:

gurpreet said...

http://www.datacompare.co.uk/
leased line, leased lines, ethernet first mile, efm uk, efm network, efm leased line, efm, Ethernet Internet, Dedicated line.
Thanks very much for your kind comments... I'm glad my blog post could be of assistance to you.

Sudhakar@gmail.com said...

Hi

I followed it but its not working. please us to solve this

sudhakar

Related Posts Plugin for WordPress, Blogger...
 

blogger templates | Make Money Online | nante aranda's random notes